• Announcements

    • megan

      Update 5: Infinite Wisdom is here!   10/05/2017

        Hey everyone, We’re back with another update that really mixes some stuff up. An entirely new challenging mode, a rebalance of the entire game to go with the rework of the new leveling progression numbers, ability to do the co-op intro online, faster PVP rounds, language translations and more! With the rebalance you’ll find that your fighters are dealing even more damage as they gain experience. All balance changes are retro-active meaning you do not have to worry about starting over or starting new characters in order to experience that – they’re all dynamically applied to what you already have! Feel free to check out what we’ve changed in the list below, and as always – please leave us feedback about anything you find noteworthy. As always, the main Story (although not included in this update) is being developed alongside all these improvements we have been releasing. Check out our blog for the full changelist: http://blog.thebehemoth.com/2017/09/28/update-5-infinite-wisdom-is-here/
    • megan

      FALL SALE! 25% OFF select merch   10/16/2017

      Time to stock up on all of our autumn appropriate threads and accessories!



      From now thru October 22, 2017 (11:59PM PST), we’ve got sweatshirts and warm plush hats on sale at 25% OFF in our online store! There are also a few other rad items like the Behemoth scarf, skate decks, and the Hatty tissue box cover on sale.

      See the full list of Fall items here: FALL SALE
Big Stein

Steam Overlay Completely Stopped Working On Mac

Recommended Posts

I've been playing CC with my friends for a good four, five hours after which - when I restarted the game - the Steam overlay stopped showing up.

 

It already sometimes didn't show up, but after quitting and restarting the game, it would be back.

I've not changed anything in the game itself nor in the Steam settings that could cause that.

 

I've tried turning off the "Steam community" and back on, deleting the game and re-installing it, restarting Steam, restarting my computer but nothing seems to work!

 

I haven't had this issue with any other games so I believe it must be specific to Castle Crashers.

 

My Mac version: 2008 iMac, OSX 10.8.2 (Mountain Lion)

 

I hope you can fix this quickly, because now I can't invite people nor get invited to the multiplayer campaign!

Share this post


Link to post
Share on other sites

Have you tried asking for help on the Steam forums as well?  You're likely to get better help there, as the Steam community is far larger than ours and would have more knowledge on such an issue.  I personally don't own a Mac, and I don't know any of the regulars around here who play on a Mac either.  I'm just saying, you're probably better off asking on Steam as well.

 

In my opinion, the main problem is with the OS itself.  Macs aren't meant to run games as much as they're built to be video rendering powerhouses.  They tend to have issues with games all of the time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now