Sign in to follow this  
Vinderex

Cc Steam: Changing Screen Resolution, Led To Crashing

Recommended Posts

I've got a problem...

The game worked great right after I bought it, but then when I tried to adjust the screen resolution, it locked up, and I had to force shut down my computer. Since then it won't even launch, it only flashes a black screen before closing immediately. Reinstalling and verifying cache hasn't helped. What can I do? Is there a hidden settings file somewhere that I could go in and manually delete in order to restore the default settings that worked?

Share this post


Link to post
Share on other sites

I've got a problem...

The game worked great right after I bought it, but then when I tried to adjust the screen resolution, it locked up, and I had to force shut down my computer. Since then it won't even launch, it only flashes a black screen before closing immediately. Reinstalling and verifying cache hasn't helped. What can I do? Is there a hidden settings file somewhere that I could go in and manually delete in order to restore the default settings that worked?

Hi this sounds like a very specific issue that we'd need more info from you to help. I'll be moving this to technical issues and I'll start up a support ticket for ya.

Share this post


Link to post
Share on other sites

I've heard a couple incidents with this so I'll merge all of those to this thread that way I can respond to the specific issues.

Share this post


Link to post
Share on other sites

Here's some info from the support team over at The Behemoth:

If you have changed the default resolution in Castle Crashers and are unable to get the game to start after that we have a solution for you. Open the start menu of your computer and in the search bar input "settings.ini". This will take you to the settings file for Castle Crashers. Open the settings.ini file with any text editing program. Change the width value to 800 and the length value to 600. Save the changes and exit the file. Attempt to launch Castle Crashers again and you should be take into gameplay. You can adjust your resolution in game again but avoid the resolution that led to the crash. We are researching the issue to get a more encompassing solution.

Share this post


Link to post
Share on other sites

Thanks a lot!

Only thing that made that solution difficult was that I had several files on my computer named "settings". But I found the one in Steam's userdata folder. So anyone else needing to do this, begin your search there. If you're on windows, that's C:/Program Files/Steam/userdata. The settings file should be in one of the subfolders, which appear to be named with an ID number, so they'll probably be different for everyone

Share this post


Link to post
Share on other sites

So I have done a similar thing that Vinderex has done. Where I adjusted the screen resolustion and then the game goes black and crashes. I have also uninstalled and reinstalled the game but the same crashing occurs. I have followed your steps to change the settings but I cannot find the settings for castle crashers. I am on Steam so I followed Steam/steamapps/common/castlecrashers but there is no settings folder to find. when I performed a flie search over my drive I found settings for various other games but not castle crashers.

I know you must get frustrated with people asking the same questions but I have read your other forums and I still cannot get it to work.

Thank you for taking the time to read this,

Sincerely, a Fan

Share this post


Link to post
Share on other sites

So I have done a similar thing that Vinderex has done. Where I adjusted the screen resolustion and then the game goes black and crashes. I have also uninstalled and reinstalled the game but the same crashing occurs. I have followed your steps to change the settings but I cannot find the settings for castle crashers. I am on Steam so I followed Steam/steamapps/common/castlecrashers but there is no settings folder to find. when I performed a flie search over my drive I found settings for various other games but not castle crashers.

I know you must get frustrated with people asking the same questions but I have read your other forums and I still cannot get it to work.

Thank you for taking the time to read this,

Sincerely, a Fan

Hi Catburgler,

I merged your topic with this one since it is very similar, so if anyone else has a similar issue then they can see this as well. I'll create a support ticket for you and when I get a response from the support team I will post it here. This way anyone with a similar issue may get a chance to find a solution too.

Share this post


Link to post
Share on other sites

So I have done a similar thing that Vinderex has done. Where I adjusted the screen resolustion and then the game goes black and crashes. I have also uninstalled and reinstalled the game but the same crashing occurs. I have followed your steps to change the settings but I cannot find the settings for castle crashers. I am on Steam so I followed Steam/steamapps/common/castlecrashers but there is no settings folder to find. when I performed a flie search over my drive I found settings for various other games but not castle crashers.

I know you must get frustrated with people asking the same questions but I have read your other forums and I still cannot get it to work.

Thank you for taking the time to read this,

Sincerely, a Fan

By the way, it is not frustration at all to help you. ;) Please let me know if you'd rather send me your make and model in private and I'll e-mail you since you aren't able to PM yet.

The easiest way to find the .ini is to follow this folder path C:Program FilesSteam (if C: is not you main hard drive replace C: with the correct letter) once in the folder search in your search bar search for the settings.ini and you will be able to find it. If you are still have problems finding after this please let us know. The resolution you want to turn it to is 800x600 after the game boots feel free to try other resolutions and follow the same steps if they crash. If you wouldn't mind please send us the make and model of you Monitor and how it is connected to you PC. Thank you very much for your time.

Share this post


Link to post
Share on other sites

A friend of mine had the same problem, we kinda did a ninja move and solved the issue. Here's what we did:

He opened the game and changed the resolution on blind mode with these instructions: First, hit Esc 2x, then enter. You'll probably be on the menu hit the down arrow 5x and enter, now you're on the Options, down 1x and enter, settings, enter again and you are on the game settings, the first option is resolution so you can change it by pushing right or left arrow, push the up arrow and enter. If you are ninja enough you will probably have solved this issue. Just keep in mind that the mouse also change switch the options, so you'd better don't move it. Hope it works!

Share this post


Link to post
Share on other sites

I had the same issue as Catbugler, but I couldn't start the game without the black screen.

I couldn't find the settings.ini anywhere, even with the search bar! I searched the Steam and Castle Crashers folders and I found nothing.

Please help!

Share this post


Link to post
Share on other sites

I had the same issue as Catbugler, but I couldn't start the game without the black screen.

I couldn't find the settings.ini anywhere, even with the search bar! I searched the Steam and Castle Crashers folders and I found nothing.

Please help!

Alexandre, did your game load successfully previously?? Also, do you hear any sound when you load it up?

Share this post


Link to post
Share on other sites

hello, i have been having similar issues, my screen is black but i can see my mouse, there is sound, and sift+tab works. please email me with some solutioons flyingmewtwo@gmail.com

Share this post


Link to post
Share on other sites

This just happend to me recently and, i try to go into settings.ini but in the settings there is nothing that says "width" and "length". This is every option: 

[Cinematics.1]
ShowIntro = "0"

[GPU.6]
GPUDeviceID = "5121"
GPUName = "NVIDIA GeForce GTX 960"
GPUScaler = "11.000000"
GPUVenderID = "4318"

[Render.13]
FullScreenRefresh = "60"
FullscreenWindow = "0"
FullscreenWindowEnabled = "1"
HorizontalFOV = "100.00000"
LastTDR = "1511034498"
WindowedFullscreen = "1"
WindowMode = "1"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this