Sign in to follow this  
tinnyx

Steam Online Multiplayer Friends Only - Game Is No Longer Available

Recommended Posts

Hello.

I have just bought Castle Crashers both for me and for my girlfriend on Steam. When we were trying to play together, we weren't able to. It always says that the "game is no longer available". We tried disabling firewall, it didn't work. When we try to join someone else's public game, I can do it just fine, but she can't even join public games. 

Can you help us somehow? It'd be really sad to find out that I've just bought two copies of the game to not be able to play together.

Share this post


Link to post
Share on other sites

Hi there, Tinnyx!

 

We'll do our best to help you out with this issue -- it would indeed be very sad if our game came between the two of you. :'(

 

Are you two on the same network? I'm assuming that Castle Crashers seems to be connecting you, but then it errors out and returns the "game is no longer available" message? 

 

Can you please ensure that all of the ports described in this article are forwarded: 

http://www.thebehemoth.com/support/ticket/kb/faq.php?id=19

 

In order to open the ports necessary to use Steam in your router, you'll first need to make sure that your computer has a static IP address. This will ensure that you're computer has the same IP address every time you use it, helping the router know where to send the traffic coming in through the open ports.
 
The gentlemen over at PortForward.com have series of fantastic guides for assigning a static IP, organized by whichever operating system you happen to be using. 
 
You can find those guides here: 
 
The next steps can be a very proprietary process depending on router manufacturers and models. With that said, PortForward.com has already done a fantastic job of creating user-friendly guides for most router makes and models.  We're going to continue directing you there throughout the rest of this guide, just to make things easier for everyone.
 
Now that you've assigned a static IP to your computer, you'll need to find a little bit of information about your router. Find your router and examine it to find out the make (who manufactured it?).  A few common manufacturers are DLINK, Linksys, Cisco and Netgear. Once you know your router's manufacturer, you're ready to head back over to PortFoward.com.
 
 
Find and click your router's manufacturer on the alphabetized list. The next screen is a list of models from that manufacturer. Take a quick look at that list to familiarize yourself with the format of the model numbers, then examine your router again for a model number. Once you find it, click that model on the list.
 
You'll now see a list of games and applications. Click on Steam Client. Carefully follow the the instructions that appear, and you're done!
 
DO NOT change anything in your router's setup page unless you're very familiar with this sort of thing. Consequences could be diresome. For reals.

 

You should also check out this Steam Support Article for more things to check!

Share this post


Link to post
Share on other sites

Hello again, thanks for your fast response.

We aren't on the same network. We tried all these things we could find on the forums, but we still weren't able to play together. Then my girlfriend had this amazing idea - she just restarted her notebook. But, to my big surprise, it worked. I suppose it was only some sort of glitch or something, I don't know.

Anyways, I'm not sure if this "method" can help someone else with this problem, I'm assuming that rebooting was only needed as a starter to some other fix we tried, but still, who knows...

Once again, thank you for your fast and thorough response, I really appreciate that. Also, I'd like to thumbs up Castle Crashers, it's really an amazing game and a ton of fun.

Share this post


Link to post
Share on other sites

My issue was cause by having multiple network adapters created by VirtualBox. On my Windows 8 machine I went into the "Network and Sharing Center" -> "Change adapter settings" and disabled all of my "VirtualBox Host-Only Network" adapters. I was then able to join multiplayer games.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this