madman5000

Castle Crashers PS4 online multiplayer game-breaking bug

Recommended Posts

Hello,

What the issue is:

The issue seems to only affect the host in online multiplayer. 

The issue seems to be when loading new areas of a level.  When players enter a new section, there is a chance that the hosts screen will just remain black and the other non-host players will see the "waiting for players" wheel at the bottom. 

As far as I could tell, the hosts black screen will remain until closing the game.  Other players connected to the host will also be kicked out of the game automatically if the host does not shut off the game in time.

This causes all leveling progress and level progression for the host to be completely lost.

This bug has been happening quite frequently with me in the night it's been released

 

"Test conditions":

-It was me playing with 2 other friends online

-i started as host and it first happened to me when entering the first forest with the thieves

-after the first incident we changed hosts and had the same issue, but I forget at which part.

-switched to having the 3rd guy be host on the level with the ram animal and his black screen event happened when trying to enter the part of the cave filled with gold that ended the level.

-we then took "shifts" being host and it kept happening everytime

 

If I had to take a shot in the dark, I'd say the root of the issue could be an incompatibility error leftover from porting the game from XBOX One to PS4

 

Thank you for taking the time to read this, I love this game and I think you guys are doing a great job.  I hope I have left enough information about it to be able to replicate the issue and solve it quickly. 

Share this post


Link to post
Share on other sites

Thank you so much for reporting this issue! We are having trouble reproducing this issue so if it's alright we had a couple of questions for you.

1. Are you experiencing any lag before this occurs?
2. Is everyone using a wireless or wired connection?

3. Can you please let me know everyone's NAT type? You can check your NAT type with the steps below.
Go to Settings and then Network menu. Now click on the view connection status option. You will see the status of your NAT on the bottom of the screen.
4. Is anyone playing on a Playstation Pro? 


Thank you, 

  • Upvote 1

Share this post


Link to post
Share on other sites

1) Some lag is occurring here and there in small pockets but nothing too crazy

2) the three connection speeds between us are 40mbps, 20mbps, and 20mbps and we are all using wireless connections

3) I know me and one of the people are type 2 because we are connected to the same router, I'm pretty sure my 3rd friend's is type 1, It could be 2 but i know it isnt 3

4) None of us are using playstation pro

 

We used to play the steam and ps3 version of the game and this issue never occurred if that helps

Share this post


Link to post
Share on other sites

Hi, i am ps4 and am having this issue every time i try to play with my friends. I am 10mbps download 2mbps upload one friend is in america at 30 down and 5 up the other is in england at 25 down and 2 up. We are all hardwired to our routers. The issue happens like the above poster says which during loading screens. Its most common for us when entering boss fights and exiting levels. However it doesnt seem to happen for the blacksmith area or shops. Love the game and really want to play it with my friends but it freezes up constantly like this.

  • Like 1

Share this post


Link to post
Share on other sites

Update: issue still persists in version 1.03 and when only connected to 1 other person. I took a video of it happening but the file is too large and I'm trying to condense it.

Share this post


Link to post
Share on other sites

Hi Madman5000, 

Thank you for all of the additional information! You will see some lagging with Nat type 2(Moderate) especially if both of you are on the same router. A couple of things you can try is directly plugging one of the ps4's directly into the router and see if this helps. Also, try and see if just one of you plays online if the lagging still occurs. Oh, one last question are you both able to connect together online you and the other person on the same router? Are you getting any laggy sections when you play together? 

Share this post


Link to post
Share on other sites

The lag isn't really the problem as most the time little to no lag occurs, today I am playing alone on the router with my friend connected on a different router.  It almost seems as if the host is getting stuck in a loop when trying to load new areas as the screen stays black and only shows when players leave.  Even if everyone else in the lobby leaves the screen will stay black if you were the host

Share this post


Link to post
Share on other sites

hello, sorry for the last post, i missclick something.

I have the exact same problem as madman5000 we are 3 playing with 3 different routers ... at the beginning there is only lag. at the scene change the host stays with the black screen and the other players waiting.

  • Like 1

Share this post


Link to post
Share on other sites

Its basically unplayable in online multiplayer. We gave up as its freezing up during loading screens or transitioning between areas.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you, everyone, for the added information and working with us on this issue. We are looking into the Black screen issue and will update this message when we have more information. 

Share this post


Link to post
Share on other sites

I can confirm that this issue is not restricted to only the main story.  Although it seems rarer, it has also occured in Arena and Back Off Barbarian as well when transitioning.

Share this post


Link to post
Share on other sites

I experienced a black screen issue this morning. Online multiplayer with two other players in the room. We initiated the Insanity mode and made it through the tall grass field. Upon using a sandwich to move the giant boulder and reach a secret area, the screen went black. I was the Blacksmith plus I was with both red and blue knights when this happened. Hopefully another bug example will help repro the issue. 

Share this post


Link to post
Share on other sites

My friends and i are also running into this issue, we are all wired. nat type 2. sumtimes lag sumtimes smoother then butter. the wierd thing is that its doesnt cuase the app to crash like when other apps freeze and we submit a bug report to ps4. i love you guys. have since newgrounds in the 90s and have owned most of your games in 1 form or another. when Castle crashers Remastered came to ps4 was super excited and convinced my friends to buy it and play. its stil a great game even with the bugs. but this gitch makes it unplayable on multiplayer with my friends

Share this post


Link to post
Share on other sites

So the game has been out a few weeks and is not playable with other online players. Im convinced at this point that the thing that keeps responding to us all is a bot thats not actually getting behemoth to work on this issue at all. All i want is to play with my friends and no one get black screened or kicked when transitioning between levels. It is not nat type problems or connection problems its a problem with behemoths servers. Please fix this or refund everyones games.

Share this post


Link to post
Share on other sites

Hi everyone! 

Fortunately, I am not a bot! 🤖

We are still very much looking into these issues but it is going to take some time to get the fixes in since we are a small team. As for the Black screen issue, since we using the PS4 P2P services not a dedicated server, it seems to occur with users that have a download speed of 3gb and below. 

We will update everyone once we have further updates!

Share this post


Link to post
Share on other sites

2 of my friends and i live in very rural areas, one of my friends live in a city, we have the best internet available to us. my download speed is usauly at a stead 12 mbs. but does drop frequently. i dont know the particulars of my friends tho...

Share this post


Link to post
Share on other sites

I bought this game with the intention to play online but it's impossible. Every transition results in black screen for the host and waiting for player for everybody else. 

I have a wired connection, nat type 2, 500Mbps trying to play with another person remotely with a wired connection, nat type 200Mbps and 100% of the attempts result in fail. 

The games lags, aways, but is "acceptable" to play, but it's rediculous to have an issue like that in 2019.

I also tested random people from internet and the results are the same which means the "explanation" of 3Gbits and bellow is not accurate. 

Please fix the game or refund everyone and stop selling the game until is fixed.

 Please feel free to reach me for further details or to help to debug this issue. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now